Results 1 to 2 of 2
  1. #1

    i need 1.24e dota version :(

    i have 1.20e version. i need 1.24e as people says it was new. how do i do it? somebody give me a link and steps for it ty

  2. #2
    http://ftp.blizzard.com/pub/war3x/patches/pc/

    Edit :

    choose your patch according to your game language
    Last edited by D2KBMH4; 08-13-2010 at 01:06 AM. Reason: ++
    b!Ng0 hhhhhhhh